I set up a mastodon instance and I’d like to interact with my lemmy instance (midwest.social) from it. Looking at the logs whenever I query a post, it returns a 200 OK with no data, but if I query a post on lemmy.ml it returns data like it should. I must have something configured wrong on my lemmy server.

Here is the log for a query:

Error encountered while processing the incoming HTTP request: lemmy_server::root_span_builder: NotFound
lemmy_1     |    0: lemmy_apub::http::post::get_apub_post
lemmy_1     |              at crates/apub/src/http/post.rs:20
lemmy_1     |    1: lemmy_server::root_span_builder::HTTP request
lemmy_1     |            with http.method=GET http.scheme="http" http.host=midwest.social http.target=/post/326295 otel.kind="server" request_id=1b0dce53-f66f-4f1d-9d6a-212de403f62a http.status_code=404 otel.status_code="OK"
seahorse
link
fedilink
53 hilabete

@seahorse Interesting, I can fetch this one now. Posting from mastodon.

@_ed@sopuli.xyz
link
fedilink
33 hilabete

FYI I subscribed to @cats@midwest and it boosted the post to the mastodon timeline. (Mastodon.social test account)

@nutomic@lemmy.ml
link
fedilink
33 hilabete

Which post specifically can you not fetch? In general your instance seems to be configured correctly.

@seahorse@midwest.social
creator
link
fedilink
33 hilabete

I think I found out what was happening. I was trying to fetch posts that had federated from a different Lemmy instance to my lemmy instance and then I was searching using that post URL instead of the original URL. It was this one https://midwest.social/post/326295.

I guess the post has to have originated from the instance that I’m searching with or it won’t return anything.

@nutomic@lemmy.ml
link
fedilink
33 hilabete

Right, you can use the fedilink in that case (colorful icon).

Support / questions about Lemmy.

  • 0 users online
  • 9 users / day
  • 24 users / week
  • 50 users / month
  • 144 users / 6 months
  • 1 subscriber
  • 172 Posts
  • 892 Comments
  • Modlog